Merge remote-tracking branch 'remotes/github/pr/157'.
[gentoo.git] / app-portage / g-cpan / g-cpan-0.16.6.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit perl-module
8 if [[ ${PV} == "9999" ]] ; then
9         EGIT_REPO_URI="git://github.com/gentoo-perl/g-cpan.git"
10         inherit git-r3
11         SRC_URI=""
12 else
13         SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.gz"
14         KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
15 fi
16
17 DESCRIPTION="g-cpan: generate and install CPAN modules using portage"
18 HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
19
20 LICENSE="|| ( Artistic GPL-2 )"
21 SLOT="0"
22 IUSE=""
23
24 DEPEND="dev-lang/perl
25                 >=dev-perl/yaml-0.60
26                 >=dev-perl/Shell-EnvImporter-1.70.0-r2
27                 dev-perl/Log-Agent"
28 RDEPEND="${DEPEND}"
29
30 src_install() {
31                 perl-module_src_install
32                 diropts "-m0755"
33                 dodir "/var/tmp/g-cpan"
34                 keepdir "/var/tmp/g-cpan"
35                 dodir "/var/log/g-cpan"
36                 keepdir "/var/log/g-cpan"
37 }
38
39 pkg_postinst() {
40         elog "You may wish to adjust the permissions on /var/tmp/g-cpan"
41         elog "if you have users besides root expecting to use g-cpan."
42         elog "Please note that some CPAN packages need additional manual"
43         elog "parameters or tweaking, due to bugs in their build systems."
44 }