app-portage/elogviewer: x86 stable (bug #658818)
[gentoo.git] / app-portage / elogviewer / elogviewer-2.7-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
7
8 DISABLE_AUTOFORMATTING=true
9
10 inherit python-single-r1 eutils readme.gentoo-r1
11
12 DESCRIPTION="Elog viewer for Gentoo"
13 HOMEPAGE="https://sourceforge.net/projects/elogviewer"
14 SRC_URI="https://github.com/Synss/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-fbsd"
19 IUSE=""
20 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21
22 RDEPEND="${PYTHON_DEPS}
23         dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
24         || (
25                 >=sys-apps/portage-2.1[${PYTHON_USEDEP}]
26                 sys-apps/portage-mgorny[${PYTHON_USEDEP}]
27         )
28         $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
29 "
30 DEPEND="${RDEPEND}
31         dev-python/setuptools[${PYTHON_USEDEP}]"
32
33 DOC_CONTENTS="In order to use this software, you need to activate
34 Portage's elog features.  Required is
35         PORTAGE_ELOG_SYSTEM=\"save\"
36 and at least one of
37         PORTAGE_ELOG_CLASSES=\"warn error info log qa\"
38 More information on the elog system can be found in
39 /usr/share/portage/config/make.conf.example
40
41 To operate properly this software needs the directory
42 ${PORT_LOGDIR:-/var/log/portage}/elog created, belonging to group portage.
43 To start the software as a user, add yourself to the portage group."
44
45 src_compile() {
46         rm -f Makefile
47 }
48
49 src_install() {
50         python_newscript elogviewer.py elogviewer
51
52         make_desktop_entry ${PN} ${PN} ${PN} System
53
54         doman elogviewer.1
55         readme.gentoo_create_doc
56 }
57
58 pkg_postinst() {
59         readme.gentoo_print_elog
60
61         ewarn "The elogviewer's configuration file is now saved in:"
62         ewarn "~/.config/elogviewer/ (was ~/.config/Mathias\ Laurin/)."
63         ewarn "Please migrate any user specific settings to the new config file."
64 }