04a1a84d43f4e6254d86f8bd8bdc4830c714099c
[gentoo.git] / app-portage / elogv / elogv-0.7.8-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{5,6,7,8} )
7 PYTHON_REQ_USE="ncurses"
8 inherit distutils-r1
9
10 DESCRIPTION="Curses based utility to parse the contents of elogs created by Portage"
11 HOMEPAGE="https://github.com/gentoo/elogv"
12 SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
17
18 RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"
19 DEPEND="${RDEPEND}"
20
21 DOCS=( README )
22
23 src_install() {
24         distutils-r1_src_install
25
26         # unset LINGUAS => install all languages
27         # empty LINGUAS => install none
28         local i
29         if [[ -n "${LINGUAS+x}" ]] ; then
30                 for i in $(ls "${ED}"/usr/share/locale/) ; do
31                         if ! has ${i} ${LINGUAS} ; then
32                                 rm -rf "${ED}"/usr/share/{locale,man}/${i}
33                         fi
34                 done
35         fi
36 }
37
38 pkg_postinst() {
39         elog "Optional dependencies:"
40         elog "  dev-python/pyliblzma (for xz compressed elog files)"
41         elog
42         elog "In order to use this software, you need to activate"
43         elog "Portage's elog features.  Required is"
44         elog "           PORTAGE_ELOG_SYSTEM=\"save\" "
45         elog "and at least one out of "
46         elog "           PORTAGE_ELOG_CLASSES=\"warn error info log qa\""
47         elog "More information on the elog system can be found"
48         elog "in ${EPREFIX}/usr/share/portage/config/make.conf.example"
49         elog
50         elog "To operate properly this software needs the directory"
51         elog "${PORT_LOGDIR:-${EPREFIX}/var/log/portage}/elog created, belonging to group portage."
52         elog "To start the software as a user, add yourself to the portage"
53         elog "group."
54         elog
55 }