Merge media-sound/spotify: Fix homepage URL
[gentoo.git] / app-pda / libusbmuxd / libusbmuxd-1.0.9.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools-utils
7
8 DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
9 HOMEPAGE="http://www.libimobiledevice.org/"
10 SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
11
12 # tools/iproxy.c is GPL-2+, everything else is LGPL-2.1+
13 LICENSE="GPL-2+ LGPL-2.1+"
14 SLOT="0/2" # based on SONAME of libusbmuxd.so
15 KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
16 IUSE="kernel_linux static-libs"
17
18 RDEPEND=">=app-pda/libplist-1.11:=
19         virtual/libusb:1
20         !=app-pda/usbmuxd-1.0.9
21         !<app-pda/usbmuxd-1.0.8_p1"
22 DEPEND="${RDEPEND}
23         virtual/os-headers
24         virtual/pkgconfig"
25
26 DOCS=( AUTHORS README )
27
28 src_configure() {
29         local myeconfargs=( $(use_enable static-libs static) )
30         use kernel_linux || myeconfargs+=( --without-inotify )
31
32         autotools-utils_src_configure
33 }