app-officeext/ooofbtools: amd64 stable wrt bug #648112
[gentoo.git] / app-officeext / ooofbtools / ooofbtools-2.52.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="OOoFBTools"
7
8 OFFICE_EXTENSIONS=(
9         "${MY_PN}.oxt"
10 )
11
12 inherit office-ext-r1
13
14 DESCRIPTION="OpenOffice extension for the FictionBook2 format with validation"
15 HOMEPAGE="https://sourceforge.net/projects/fbtools/"
16 SRC_URI="mirror://sourceforge/fbtools/files/release/${MY_PN}-${PV}.zip"
17
18 LICENSE="GPL-3"
19 SLOT="0"
20 KEYWORDS="amd64 x86"
21
22 RDEPEND="dev-libs/libxml2
23         app-arch/zip"
24
25 S="${WORKDIR}/${MY_PN}-${PV}"
26
27 OFFICE_EXTENSIONS_LOCATION="${S}"
28
29 src_prepare() {
30         # Remove Windows cruft
31         pushd "${WORKDIR}/${MY_PN}.oxt" &>/dev/null || die
32         rm -r win32 || die
33         popd &>/dev/null || die
34
35         eapply_user
36 }
37
38 src_install() {
39         office-ext-r1_src_install
40         dodoc ChangeLog*
41 }