Stable on Alpha, bug 166246.
[gentoo.git] / app-office / kexi / kexi-1.6.1.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6.1.ebuild,v 1.9 2007/02/15 00:44:39 kloeri Exp $
4
5 MAXKOFFICEVER=${PV}
6 KMNAME=koffice
7 inherit kde-meta eutils
8
9 DESCRIPTION="KOffice integrated environment for database management."
10 HOMEPAGE="http://www.koffice.org/"
11 LICENSE="GPL-2 LGPL-2"
12
13 SLOT="0"
14 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
15 IUSE="mysql postgres kdeenablefinal"
16
17 RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
18         sys-libs/readline
19         mysql? ( virtual/mysql )
20         postgres? ( dev-libs/libpqxx )"
21
22 DEPEND="${RDEPEND}
23         dev-util/pkgconfig"
24
25 KMCOPYLIB="
26         libkformula lib/kformula
27         libkofficecore lib/kofficecore
28         libkofficeui lib/kofficeui
29         libkopainter lib/kopainter
30         libkoproperty lib/koproperty
31         libkotext lib/kotext
32         libkwmf lib/kwmf
33         libkowmf lib/kwmf
34         libkstore lib/store
35         libkrossmain lib/kross/main/
36         libkrossapi lib/kross/api/"
37
38 KMEXTRACTONLY="lib/"
39
40 need-kde 3.4
41
42 src_compile() {
43         local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"
44
45         kde-meta_src_compile
46 }