1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-office/kexi/kexi-1.6.1.ebuild,v 1.9 2007/02/15 00:44:39 kloeri Exp $
7 inherit kde-meta eutils
9 DESCRIPTION="KOffice integrated environment for database management."
10 HOMEPAGE="http://www.koffice.org/"
11 LICENSE="GPL-2 LGPL-2"
14 KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
15 IUSE="mysql postgres kdeenablefinal"
17 RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
19 mysql? ( virtual/mysql )
20 postgres? ( dev-libs/libpqxx )"
26 libkformula lib/kformula
27 libkofficecore lib/kofficecore
28 libkofficeui lib/kofficeui
29 libkopainter lib/kopainter
30 libkoproperty lib/koproperty
35 libkrossmain lib/kross/main/
36 libkrossapi lib/kross/api/"
43 local myconf="$(use_enable mysql) $(use_enable postgres pgsql) --enable-kexi-reports"