dev-python/cherrypy: keyworded 18.5.0 for ia64, bug #717946
[gentoo.git] / app-office / glabels / glabels-3.4.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 inherit eutils gnome2
6
7 DESCRIPTION="Program for creating labels and business cards"
8 HOMEPAGE="http://www.glabels.org/"
9
10 LICENSE="GPL-3+ LGPL-3+ CC-BY-SA-3.0 MIT"
11 SLOT="0"
12 KEYWORDS="amd64 ~ppc ~sparc x86"
13 IUSE="barcode eds"
14
15 RDEPEND="
16         >=dev-libs/glib-2.42.0:2
17         >=x11-libs/gtk+-3.14.0:3
18         >=dev-libs/libxml2-2.9.0:2
19         >=gnome-base/librsvg-2.39.0:2
20         >=x11-libs/cairo-1.14.0
21         >=x11-libs/pango-1.36.1
22         barcode? (
23                 >=app-text/barcode-0.98
24                 >=media-gfx/qrencode-3.1 )
25         eds? ( >=gnome-extra/evolution-data-server-3.12.0:= )
26 "
27 DEPEND="${RDEPEND}
28         app-text/docbook-xml-dtd:4.1.2
29         dev-util/itstool
30         dev-util/gtk-doc-am
31         >=dev-util/intltool-0.28
32         virtual/pkgconfig
33 "
34
35 src_configure() {
36         gnome2_src_configure \
37                 $(use_with eds libebook) \
38                 --disable-static
39 }