Globally add missing remote ID references to metadata.xml
[gentoo.git] / app-mobilephone / dfu-util / dfu-util-9999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ ${PV} == "9999" ]] ; then
7         EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
8         inherit autotools git-r3
9 else
10         SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11         KEYWORDS="~amd64 ~x86"
12 fi
13
14 DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
15 HOMEPAGE="http://dfu-util.sourceforge.net/"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19
20 RDEPEND="virtual/libusb:1"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig"
23
24 src_prepare() {
25         default
26         [[ ${PV} == "9999" ]] && eautoreconf
27 }