www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / app-misc / worker / worker-3.8.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone"
9 HOMEPAGE="http://www.boomerangsworld.de/cms/worker/"
10 SRC_URI="http://www.boomerangsworld.de/cms/worker/downloads/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ~hppa ppc ~ppc64 x86"
15 IUSE="avfs debug dbus examples libnotify lua +magic xinerama xft"
16
17 RDEPEND="x11-libs/libX11
18         avfs? ( >=sys-fs/avfs-0.9.5 )
19         dbus? ( dev-libs/dbus-glib )
20         lua? ( dev-lang/lua:0 )
21         magic? ( sys-apps/file )
22         xft? ( x11-libs/libXft )
23         xinerama? ( x11-libs/libXinerama )"
24 DEPEND="${RDEPEND}"
25
26 DOCS=( AUTHORS ChangeLog INSTALL NEWS README README_LARGEFILES THANKS )
27
28 src_configure() {
29         # there is no ./configure flag to disable libXinerama support
30         export ac_cv_lib_Xinerama_XineramaQueryScreens=$(usex xinerama)
31         econf \
32                 --without-hal \
33                 --enable-utf8 \
34                 $(use_with avfs) \
35                 $(use_with dbus) \
36                 $(use_enable debug) \
37                 $(use_enable libnotify inotify) \
38                 $(use_enable lua) \
39                 $(use_with magic libmagic) \
40                 $(use_enable xft)
41 }
42
43 src_compile() {
44         emake -j1
45 }
46
47 src_install() {
48         default
49
50         if use examples; then
51                 docinto examples
52                 dodoc examples/config-*
53         fi
54 }