app-misc/gtypist: fix crash and upgrade EAPI
[gentoo.git] / app-misc / terminal-colors / terminal-colors-2.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python3_6 )
6 PYTHON_REQ_USE="ncurses"
7
8 inherit python-r1
9
10 DESCRIPTION="A tool to display color charts for 8, 16, 88, and 256 color terminals"
11 HOMEPAGE="http://zhar.net/projects/shell/terminal-colors"
12 SRC_URI="https://dev.gentoo.org/~radhermit/distfiles/${P}.bz2"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="amd64 x86 ~x64-macos"
17 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
18
19 RDEPEND="${PYTHON_DEPS}"
20
21 S=${WORKDIR}
22
23 src_install() {
24         python_foreach_impl python_newscript ${P} ${PN}
25 }