app-misc/tracker: x86 stable wrt bug #717144
[gentoo.git] / app-misc / slmon / slmon-0.5.13.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools eutils
6
7 DESCRIPTION="Colored text-based system performance monitor"
8 HOMEPAGE="http://slmon.sourceforge.net"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 x86"
14 IUSE="debug"
15
16 RDEPEND="
17         dev-libs/glib:2
18         sys-libs/slang
19         gnome-base/libgtop
20 "
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23 "
24
25 src_prepare() {
26         epatch "${FILESDIR}"/${P}-make-382.patch \
27                 "${FILESDIR}"/${P}-invalid-free.patch
28         eautoreconf
29 }
30
31 src_configure() {
32         econf $(use_enable debug)
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install
37         dodoc AUTHORS ChangeLog README slmonrc TODO
38         dohtml *.html
39 }