proj/gentoo: Initial commit
[gentoo.git] / app-misc / sleepyhead / sleepyhead-0.9.3.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit eutils qt4-r2
7 DESCRIPTION="Software used to analyze data from CPAP machines"
8 HOMEPAGE="https://sourceforge.net/apps/mediawiki/sleepyhead/index.php?title=Main_Page"
9
10 # Point to any required sources; these will be automatically downloaded by
11 # Portage.
12 SRC_URI="https://github.com/rich0/rich0-sleepyhead/tarball/${PV} -> ${P}.tgz"
13 LICENSE="GPL-2"
14 SLOT="0"
15
16 KEYWORDS="~amd64"
17
18 IUSE=""
19
20 DEPEND="virtual/opengl
21                 x11-libs/libX11
22                 dev-qt/qtcore:4
23                 dev-qt/qtgui:4
24                 dev-qt/qtopengl:4
25                 dev-qt/qtwebkit:4
26                 virtual/glu"
27 RDEPEND="${DEPEND}"
28
29 S="${WORKDIR}/rich0-rich0-sleepyhead-34e0b92"
30
31 src_unpack() {
32         unpack ${A}
33         cd "${S}"
34 }
35
36 src_prepare() {
37 #       qt4_src_prepare
38         cd "{$S}"
39         epatch "${FILESDIR}/common_gui.patch"
40
41 #       sed -i '1i#define OF(x) x' quazip/ioapi.h quazip/unzip.c quazip/unzip.h \
42 #          quazip/zip.c quazip/zip.h quazip/zlib.h
43         eqmake4 SleepyHeadQT.pro
44 }
45
46 src_install() {
47         cd "{$S}"
48         dobin SleepyHead || die
49         dodoc README || die
50         dodoc docs/* || die
51 }