sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / app-misc / sl / sl-5.02.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="sophisticated graphical program which corrects your miss typing"
9 HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html https://github.com/mtoyoda/sl/"
10 SRC_URI="https://github.com/mtoyoda/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Toyoda"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 ~arm hppa ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
15 IUSE="l10n_ja"
16
17 RDEPEND="sys-libs/ncurses:0="
18 DEPEND="${RDEPEND}"
19
20 DOCS=( README.md )
21
22 src_prepare() {
23         default
24         sed \
25             -e "s/-lncurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" \
26                 -i Makefile || die
27 }
28
29 src_install() {
30         dobin "${PN}"
31         doman "${PN}.1"
32
33         if use l10n_ja; then
34                 newman "${PN}.1.ja" "${PN}.ja.1"
35                 DOCS+=( README.ja.md )
36         fi
37
38         einstalldocs
39 }