app-misc/pax-utils: arm stable wrt bug #725010
[gentoo.git] / app-misc / skim / skim-0.8.1.ebuild
1 # Copyright 2017-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CRATES="
7 aho-corasick-0.7.3
8 ansi_term-0.11.0
9 arrayref-0.3.6
10 arrayvec-0.4.10
11 arrayvec-0.5.1
12 atty-0.2.11
13 autocfg-0.1.7
14 base64-0.11.0
15 bitflags-1.0.4
16 blake2b_simd-0.5.10
17 cc-1.0.31
18 cfg-if-0.1.7
19 chrono-0.4.6
20 clap-2.32.0
21 constant_time_eq-0.1.5
22 crossbeam-0.7.3
23 crossbeam-channel-0.4.0
24 crossbeam-deque-0.2.0
25 crossbeam-deque-0.7.2
26 crossbeam-epoch-0.3.1
27 crossbeam-epoch-0.8.0
28 crossbeam-queue-0.2.1
29 crossbeam-utils-0.2.2
30 crossbeam-utils-0.7.0
31 darling-0.10.2
32 darling_core-0.10.2
33 darling_macro-0.10.2
34 derive_builder-0.9.0
35 derive_builder_core-0.9.0
36 dirs-2.0.2
37 dirs-sys-0.3.4
38 either-1.5.1
39 env_logger-0.6.1
40 fnv-1.0.6
41 fuzzy-matcher-0.3.4
42 getrandom-0.1.6
43 humantime-1.2.0
44 ident_case-1.0.1
45 lazy_static-1.3.0
46 libc-0.2.58
47 log-0.4.6
48 memchr-2.2.0
49 memoffset-0.2.1
50 memoffset-0.5.3
51 nix-0.14.0
52 nodrop-0.1.13
53 num-integer-0.1.39
54 num-traits-0.2.6
55 num_cpus-1.10.0
56 proc-macro2-1.0.6
57 quick-error-1.2.2
58 quote-1.0.2
59 rayon-1.0.3
60 rayon-core-1.4.1
61 redox_syscall-0.1.51
62 redox_termios-0.1.1
63 redox_users-0.3.4
64 regex-1.1.6
65 regex-syntax-0.6.6
66 rust-argon2-0.7.0
67 rustc_version-0.2.3
68 scopeguard-0.3.3
69 scopeguard-1.0.0
70 semver-0.9.0
71 semver-parser-0.7.0
72 shlex-0.1.1
73 skim-0.8.1
74 spin-0.5.2
75 strsim-0.7.0
76 strsim-0.9.3
77 syn-1.0.11
78 term-0.6.1
79 termcolor-1.0.4
80 termion-1.5.1
81 textwrap-0.10.0
82 thread_local-0.3.6
83 thread_local-1.0.0
84 time-0.1.42
85 timer-0.2.0
86 tuikit-0.3.2
87 ucd-util-0.1.3
88 unicode-width-0.1.5
89 unicode-xid-0.2.0
90 utf8-ranges-1.0.2
91 utf8parse-0.1.1
92 vec_map-0.8.1
93 void-1.0.2
94 vte-0.3.3
95 winapi-0.3.6
96 winapi-i686-pc-windows-gnu-0.4.0
97 winapi-util-0.1.2
98 winapi-x86_64-pc-windows-gnu-0.4.0
99 wincolor-1.0.1
100 "
101
102 inherit cargo
103
104 DESCRIPTION="Command-line fuzzy finder"
105 HOMEPAGE="https://github.com/lotabout/skim"
106 SRC_URI="$(cargo_crate_uris ${CRATES})"
107
108 LICENSE="Apache-2.0 MIT MPL-2.0 Unlicense"
109 SLOT="0"
110 KEYWORDS="~amd64 ~ppc64 ~x86"
111 IUSE="tmux vim"
112
113 RDEPEND="
114         tmux? ( app-misc/tmux )
115         vim? ( || ( app-editors/vim app-editors/gvim ) )
116 "
117
118 QA_FLAGS_IGNORED="usr/bin/sk"
119
120 src_install() {
121         # prevent cargo_src_install() blowing up on man installation
122         mv man manpages || die
123
124         cargo_src_install
125         dodoc CHANGELOG.md README.md
126         doman manpages/man1/*
127
128         use tmux && dobin bin/sk-tmux
129
130         if use vim; then
131                 insinto /usr/share/vim/vimfiles/plugin
132                 doins plugin/skim.vim
133         fi
134
135         # install bash/zsh completion and keybindings
136         # since provided completions override a lot of commands, install to /usr/share
137         insinto /usr/share/${PN}
138         doins shell/{*.bash,*.zsh}
139 }