app-misc/abook: Fix link to tinfo and vformat
[gentoo.git] / app-misc / reptyr / reptyr-0.6.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs flag-o-matic vcs-snapshot
7
8 DESCRIPTION="A utility to attach a running program to a new terminal"
9 HOMEPAGE="https://github.com/nelhage/reptyr"
10 SRC_URI="https://github.com/nelhage/${PN}/archive/${P}.tar.gz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
15
16 RESTRICT="test"
17
18 # https://github.com/nelhage/reptyr/issues/81
19 SRC_URI+=" https://github.com/nelhage/reptyr/commit/b45fd9238958fcf2d8f3d6fc23e6d491febea2ac.patch -> ${PN}-0.6.2-sysmacros.patch"
20
21 PATCHES=(
22         "${DISTDIR}/${P}-sysmacros.patch" #581974
23 )
24
25 src_prepare() {
26         default
27         # respect CFLAGS
28         sed -i '/^override/d' Makefile || die
29 }
30
31 src_compile() {
32         append-cppflags -D_GNU_SOURCE
33         emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
38         dodoc ChangeLog NOTES README.md
39 }