dev-qt/qtprintsupport: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-misc / regionset / regionset-0.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Sets the region on DVD drives"
9 HOMEPAGE="http://linvdr.org/projects/regionset/"
10 SRC_URI="http://linvdr.org/download/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15 IUSE=""
16
17 src_prepare() {
18         sed "/^\.IR/s@${PN}@${PF}@" -i ${PN}.8 || die
19 }
20
21 src_compile() {
22         $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c dvd_udf.c || die
23 }
24
25 src_install() {
26         dosbin ${PN}
27         doman ${PN}.8
28         dodoc debian/changelog README
29 }
30
31 pkg_postinst() {
32         ewarn "By default regionset uses /dev/dvd, specify a different device"
33         ewarn "as a command line argument if you need to. You need write access"
34         ewarn "to do this, preferably as root."
35         ewarn
36         ewarn "Most drives can only have their region changed 4 or 5 times."
37         ewarn
38         ewarn "When you use regionset, you MUST have a cd or dvd in the drive"
39         ewarn "otherwise nasty things will happen to your drive's firmware."
40 }