app-misc/pwsafe-0.2.0-r4: amd64 stable
[gentoo.git] / app-misc / pwsafe / pwsafe-0.2.0-r2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5 inherit base eutils
6
7 DESCRIPTION="A Password Safe compatible command-line password manager"
8 HOMEPAGE="http://nsd.dyndns.org/pwsafe/"
9 SRC_URI="http://nsd.dyndns.org/pwsafe/releases/${P}.tar.gz"
10 PATCHES=(
11                         "${FILESDIR}/${P}-cvs-1.57.patch"
12                         "${FILESDIR}/${P}-printf.patch"
13                         "${FILESDIR}/${P}-fake-readline.patch"
14                         "${FILESDIR}/${P}-man-page-option-syntax.patch"
15                         "${FILESDIR}/${P}-XChangeProperty.patch"
16                 )
17
18 LICENSE="GPL-2"
19 SLOT="0"
20 KEYWORDS="amd64 x86"
21
22 IUSE="X readline"
23
24 DEPEND="sys-libs/ncurses
25         dev-libs/openssl
26         readline? ( sys-libs/readline )
27         X? ( x11-libs/libSM
28                 x11-libs/libICE
29                 x11-libs/libXmu
30                 x11-libs/libX11 )"
31 RDEPEND="${DEPEND}"
32
33 src_configure() {
34         econf $(use_with X x) $(use_with readline)
35 }
36
37 src_install() {
38         doman pwsafe.1
39         dobin pwsafe
40         dodoc README NEWS
41 }