dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-misc / oneko / oneko-1.2-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="A cat, dog and others which chase the mouse or windows around the screen"
8 HOMEPAGE="http://www.daidouji.com/oneko/"
9 SRC_URI="http://www.daidouji.com/oneko/distfiles/${P}.sakura.5.tar.gz
10         mirror://gentoo/${P}-cat.png
11         mirror://gentoo/${P}-dog.png
12         mirror://gentoo/${P}-sakura-nobsd.patch.bz2"
13
14 LICENSE="public-domain"
15 SLOT="0"
16 KEYWORDS="amd64 ppc ppc64 x86"
17
18 RDEPEND="
19         x11-libs/libX11
20         x11-libs/libXext
21 "
22 DEPEND="
23         ${RDEPEND}
24         app-text/rman
25         x11-base/xorg-proto
26         x11-misc/gccmakedep
27         x11-misc/imake
28 "
29
30 S=${WORKDIR}/oneko-${PV}.sakura.5
31
32 src_prepare() {
33         epatch \
34                 "${WORKDIR}"/${P}-sakura-nobsd.patch \
35                 "${FILESDIR}"/${P}-include.patch
36 }
37
38 src_configure() {
39         xmkmf -a || die
40 }
41
42 src_compile() {
43         emake \
44                 CC="$(tc-getCC)" \
45                 CCOPTIONS="${CFLAGS}" \
46                 EXTRA_LDOPTIONS="${LDFLAGS}"
47 }
48
49 src_install() {
50         dobin oneko
51         newman oneko._man oneko.1x
52         dodoc README README-NEW README-SUPP
53         newicon "${DISTDIR}/${P}-cat.png" "cat.png"
54         newicon "${DISTDIR}/${P}-dog.png" "dog.png"
55         make_desktop_entry "oneko" "oneko (cat)" "cat" "Game;Amusement"
56         make_desktop_entry "oneko -dog" "oneko (dog)" "dog" "Game;Amusement"
57         make_desktop_entry "killall -TERM oneko" "oneko kill" "" "Game;Amusement"
58 }
59
60 pkg_postinst() {
61         elog "To kill oneko, type the following in a terminal:"
62         elog ""
63         elog "killall oneko"
64         elog ""
65         elog "If your mouse cursor changes to the default black cross"
66         elog "after running ${PN}, you should emerge x11-apps/xsetroot"
67         elog "and run:"
68         elog ""
69         elog "xsetroot -cursor_name left_ptr"
70         elog ""
71 }