dev-python/numpydoc: arm64 keyworded (bug #721130)
[gentoo.git] / app-misc / note / note-1.3.3-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit perl-module
7
8 DESCRIPTION="A note taking perl program"
9 HOMEPAGE="https://www.daemon.de/NOTE"
10 SRC_URI="https://www.daemon.de/idisk/Apps/note/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE="crypt dbm general mysql text"
16
17 DEPEND="dev-perl/TermReadKey
18         dev-perl/Term-ReadLine-Perl
19         virtual/perl-Storable
20         dev-perl/Config-General
21         crypt? ( dev-perl/Crypt-CBC
22                 dev-perl/Crypt-Blowfish
23                 dev-perl/Crypt-DES )
24         mysql? ( dev-perl/DBD-mysql )"
25 RDEPEND="${DEPEND}"
26
27 # extraneous README that gets installed into the perl module
28 PERL_RM_FILES=( NOTEDB/README )
29
30 src_prepare() {
31         # Supressing file not needed
32         local v
33         for v in mysql text dbm general; do
34                 if ! use ${v}; then
35                         PERL_RM_FILES+=( NOTEDB/${v}.pm )
36                 fi
37         done
38         perl-module_src_prepare
39 }
40
41 src_install() {
42         perl-module_src_install
43
44         # Adding some basic utitily for testing note
45         exeinto /usr/share/${PN}
46         doexe bin/stresstest.sh
47
48         # Adding some help for mysql backend driver
49         if use mysql; then
50                 insinto /usr/share/${PN}/mysql
51                 exeinto /usr/share/${PN}/mysql
52                 doins mysql/{README,sql,permissions}
53                 doexe mysql/install.sh
54         fi
55
56         # Adding a sample configuration file
57         insinto /etc
58         doins config/noterc
59
60         dodoc UPGRADE VERSION
61 }