Merge github#363: sys-process/atop: add systemd support
[gentoo.git] / app-misc / note / note-1.3.3-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit perl-module
8
9 DESCRIPTION="A note taking perl program"
10 HOMEPAGE="http://www.daemon.de/NOTE"
11 SRC_URI="http://www.daemon.de/files/mirror/ftp.daemon.de/scip/Apps/note/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc x86"
16 IUSE="crypt dbm general mysql text"
17
18 DEPEND="dev-perl/TermReadKey
19         dev-perl/Term-ReadLine-Perl
20         virtual/perl-Storable
21         dev-perl/Config-General
22         crypt? ( dev-perl/Crypt-CBC
23                 dev-perl/Crypt-Blowfish
24                 dev-perl/Crypt-DES )
25         mysql? ( virtual/mysql
26                 dev-perl/DBD-mysql )"
27 RDEPEND=""
28
29 src_install() {
30         perl-module_src_install
31
32         # Adding some basic utitily for testing note
33         dodir /usr/share/${PN}
34         cp "${S}/bin/stresstest.sh" "${D}/usr/share/${PN}"
35
36         # Adding some help for mysql backend driver
37         if use mysql; then
38                 dodir /usr/share/${PN}/mysql
39                 cp -r "${S}/mysql" "${D}/usr/share/${PN}"
40         fi
41
42         # Adding a sample configuration file
43         dodir /etc
44         cp "${S}/config/noterc" "${D}/etc"
45
46         # Supressing file not needed
47         for v in mysql text dbm general; do
48                 if ! use ${v}; then
49                         for u in `find "${D}" -type f -name *${v}.*pm`; do
50                                 rm "${u}"
51                         done
52                 fi
53         done
54
55         dodoc UPGRADE VERSION
56 }