sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / app-misc / mepl / mepl-0.45-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Self-employed-mode software for 3COM/USR message modems"
9 HOMEPAGE="https://web.archive.org/web/20031204100644/http://www.hof-berlin.de:80/mepl/"
10 SRC_URI="http://www.hof-berlin.de/mepl/mepl${PV}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15
16 S="${WORKDIR}/${PN}${PV}"
17
18 PATCHES=( "${FILESDIR}/${P}-gcc433.patch" )
19
20 src_compile() {
21         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -DMEPLCONFIG=\\\"/etc/mepl.conf\\\" ${LDFLAGS}" en
22 }
23
24 src_install() {
25         dobin "${PN}" "${PN}mail"
26         insinto /etc
27         doins "${PN}.conf"
28         newman "${PN}.en" "${PN}.7"
29 }