app-misc/gourmet: Fix metadata.xml file.
[gentoo.git] / app-misc / hivex / hivex-1.3.11-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 AUTOTOOLS_IN_SOURCE_BUILD=1
8
9 USE_RUBY="ruby20 ruby21"
10 RUBY_OPTIONAL=yes
11
12 PYTHON_COMPAT=(python2_7 python3_{3,4})
13
14 inherit autotools-utils eutils perl-app ruby-ng python-single-r1
15
16 DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
17 HOMEPAGE="http://libguestfs.org"
18 SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
19
20 LICENSE="LGPL-2.1"
21 SLOT="0"
22 KEYWORDS="~amd64 ~x86"
23 IUSE="ocaml readline +perl python test static-libs ruby"
24
25 RDEPEND="
26         virtual/libiconv
27         virtual/libintl
28         dev-libs/libxml2:2
29         ocaml? ( dev-lang/ocaml[ocamlopt]
30                          dev-ml/findlib[ocamlopt]
31                          )
32         readline? ( sys-libs/readline )
33         perl? ( dev-perl/IO-stringy )
34         ruby? ( $(ruby_implementations_depend) )
35         python? ( ${PYTHON_DEPS} )
36         "
37
38 DEPEND="${RDEPEND}
39         dev-lang/perl
40         perl? (
41                 test? ( dev-perl/Pod-Coverage
42                         dev-perl/Test-Pod-Coverage )
43                   )
44         "
45
46 ruby_add_bdepend "ruby? ( dev-ruby/rake
47                         virtual/rubygems
48                         dev-ruby/rdoc )"
49 ruby_add_rdepend "ruby? ( virtual/rubygems )"
50
51 REQUIRED_USE="python? ( ${PYTHON_REQ_USE} )"
52
53 DOCS=( README )
54 S="${WORKDIR}/${P}"
55
56 #We are aware of rather poor quality of this ebuild, but the bump is required to fix security bug. We will fix other matters later.
57
58 pkg_setup() {
59         if use python; then
60                 python-single-r1_pkg_setup
61         fi
62         if use perl; then
63                 perl_set_version
64         fi
65 }
66
67 src_unpack() {
68         default
69 }
70
71 src_prepare() {
72         epatch_user
73 }
74
75 src_configure() {
76         local myeconfargs=(
77                 $(use_with readline)
78                 $(use_enable ocaml)
79                 $(use_enable perl)
80                 --enable-nls
81                 $(use_enable python)
82                 $(use_enable ruby)
83                 --disable-rpath )
84
85         autotools-utils_src_configure
86
87         if use perl; then
88                 pushd perl
89                 perl-app_src_configure
90                 popd
91         fi
92 }
93
94 src_compile() {
95         autotools-utils_src_compile
96 }
97
98 # Test binding's dont't wok properly in gentoo layout
99 #src_test() {
100 #       if use perl;then
101 #               pushd perl
102 #               perl-app_src_install
103 #               popd
104 #       fi
105 #
106 #       autotools-utils_src_compile check
107 #}
108
109 src_install() {
110         strip-linguas -i po
111
112         autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
113
114         if use perl; then
115                 perl_delete_localpod
116         fi
117 }