app-misc/mswinurl_launcher: rescue from sunrise
[gentoo.git] / app-misc / hachoir-urwid / hachoir-urwid-1.1-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8 PYTHON_REQ_USE="ncurses"
9
10 inherit distutils-r1
11
12 DESCRIPTION="Binary file explorer using Hachoir and urwid libraries"
13 HOMEPAGE="https://bitbucket.org/haypo/hachoir/wiki/hachoir-urwid https://pypi.python.org/pypi/hachoir-urwid"
14 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-python/hachoir-core-1.2[${PYTHON_USEDEP}]
22         >=dev-python/hachoir-parser-1.0[${PYTHON_USEDEP}]
23         >=dev-python/urwid-0.9.4[${PYTHON_USEDEP}]"
24 DEPEND="${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]"
26
27 python_configure_all() {
28         mydistutilsargs=(
29                 --setuptools
30         )
31 }