app-misc/screenfetch: Remove 3.7.0
[gentoo.git] / app-misc / hachoir-urwid / hachoir-urwid-1.1-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7 PYTHON_REQ_USE="ncurses"
8
9 inherit distutils-r1
10
11 DESCRIPTION="Binary file explorer using Hachoir and urwid libraries"
12 HOMEPAGE="https://web.archive.org/web/20161220110246/https://bitbucket.org/haypo/hachoir/wiki/hachoir-urwid https://pypi.org/project/hachoir-urwid/"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-python/hachoir-core-1.2[${PYTHON_USEDEP}]
21         >=dev-python/hachoir-parser-1.0[${PYTHON_USEDEP}]
22         >=dev-python/urwid-0.9.4[${PYTHON_USEDEP}]"
23 DEPEND="${RDEPEND}
24         dev-python/setuptools[${PYTHON_USEDEP}]"
25
26 python_configure_all() {
27         mydistutilsargs=(
28                 --setuptools
29         )
30 }