sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / app-misc / grabcartoons / grabcartoons-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ ${PV} == *9999 ]] ; then
7         inherit git-r3
8         EGIT_REPO_URI="https://github.com/zzamboni/grabcartoons.git"
9 else
10         inherit vcs-snapshot
11         SRC_URI="https://github.com/zzamboni/grabcartoons/archive/cb230f01fb288a0b9f0fc437545b97d06c846bd3.tar.gz -> ${P}.tar.gz"
12         KEYWORDS="~amd64 ~x86"
13 fi
14
15 DESCRIPTION="Comic-summarizing utility"
16 HOMEPAGE="https://zzamboni.org/code/grabcartoons/"
17
18 LICENSE="BSD"
19 SLOT="0"
20 IUSE=""
21 # Opens a web page, which is unacceptable during an emerge.
22 RESTRICT="test"
23
24 RDEPEND="
25         dev-lang/perl
26         virtual/perl-Getopt-Long"
27
28 PATCHES=( "${FILESDIR}"/2.8.4-fix-install-paths.patch )
29
30 src_install() {
31         emake PREFIX="${ED%/}"/usr install
32         einstalldocs
33 }