www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / app-misc / gnote / gnote-3.30.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 GNOME2_LA_PUNT="yes"
6
7 inherit gnome2 readme.gentoo-r1
8
9 DESCRIPTION="Desktop note-taking application"
10 HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
11
12 LICENSE="GPL-3+ FDL-1.1"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="debug"
16
17 # Automagic:
18 # glib-2.32 dep
19 # >=dev-libs/unittest++-1.5.1 (but not detected due to missing .pc)
20 # glibmm: first version in tree providing Thread API fix
21 COMMON_DEPEND="
22         >=app-crypt/libsecret-0.8
23         >=app-text/gtkspell-3.0:3
24         >=dev-cpp/glibmm-2.52.1-r1:2
25         >=dev-cpp/gtkmm-3.18:3.0
26         >=dev-libs/glib-2.32:2[dbus]
27         >=dev-libs/libxml2-2:2
28         dev-libs/libxslt
29         >=sys-apps/util-linux-2.16:=
30         >=x11-libs/gtk+-3.20:3
31 "
32 RDEPEND="${COMMON_DEPEND}
33         gnome-base/gsettings-desktop-schemas
34 "
35 DEPEND="${DEPEND}
36         app-text/docbook-xml-dtd:4.1.2
37         >=dev-util/intltool-0.35.0
38         dev-util/itstool
39         virtual/pkgconfig
40 "
41
42 src_prepare() {
43         # Do not alter CFLAGS
44         sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die
45
46         gnome2_src_prepare
47
48         if has_version net-fs/wdfs; then
49                 DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
50                 synchronize notes."
51         else
52                 DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
53                 If you want to use that functionality just emerge net-fs/wdfs.
54                 Gnote will automatically detect that you did and let you use it."
55         fi
56 }
57
58 src_configure() {
59         gnome2_src_configure \
60                 --disable-static \
61                 $(use_enable debug)
62 }
63
64 src_install() {
65         gnome2_src_install
66         readme.gentoo_create_doc
67 }
68
69 pkg_postinst() {
70         gnome2_pkg_postinst
71         readme.gentoo_print_elog
72 }