dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-misc / g15mpd / g15mpd-1.0.0-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools eutils
6
7 DESCRIPTION="MPD (music player daemon) plugin to G15daemon"
8 HOMEPAGE="https://sourceforge.net/projects/g15daemon/"
9 SRC_URI="mirror://sourceforge/g15daemon/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 RDEPEND="
17         >=app-misc/g15daemon-1.9
18         dev-libs/libg15
19         dev-libs/libg15render
20         >=media-libs/libmpd-0.17
21         sys-libs/zlib
22         x11-libs/libX11
23         x11-libs/libXtst
24 "
25 DEPEND="${RDEPEND}
26         x11-base/xorg-proto"
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${P}-libmpd.patch
30         epatch "${FILESDIR}/${PN}-1.0.0-cflags-and-lib-fix.patch"
31         eautoreconf
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install
36         rm "${D}"/usr/share/doc/${P}/{COPYING,NEWS}
37 }