app-misc/mswinurl_launcher: rescue from sunrise
[gentoo.git] / app-misc / fdupes / fdupes-1.51.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils flag-o-matic toolchain-funcs
8
9 MY_P="${PN}-${PV/_pre/-PR}"
10
11 DESCRIPTION="Identify/delete duplicate files residing within specified directories"
12 HOMEPAGE="https://github.com/adrianlopezroche/fdupes https://code.google.com/p/fdupes/"
13 SRC_URI="
14         https://fdupes.googlecode.com/files/${P}.tar.gz
15         https://github.com/adrianlopezroche/${PN}/archive/${P}.tar.gz
16         "
17
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
21 IUSE=""
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_prepare() {
26         epatch \
27                 "${FILESDIR}"/${P}-makefile.patch \
28                 "${FILESDIR}"/${PN}-1.50_pre2-compare-file.patch \
29                 "${FILESDIR}"/${PN}-1.50_pre2-typo.patch \
30                 "${FILESDIR}"/${P}-fix-stdin-lvalue.patch
31
32         append-lfs-flags
33 }
34
35 src_compile() {
36         emake CC=$(tc-getCC)
37 }
38
39 src_install() {
40         dobin fdupes
41         doman fdupes.1
42         dodoc CHANGES CONTRIBUTORS README TODO
43 }