app-misc/elasticsearch: bump to 7.5.2, drop old
[gentoo.git] / app-misc / enum / enum-1.1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="Replacement for GNU seq and BSD jot"
9 HOMEPAGE="https://github.com/hartwork/enum"
10 SRC_URI="https://github.com/hartwork/enum/archive/${PV}.tar.gz -> ${P}.tar.gz"
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="app-text/asciidoc"
17 RDEPEND=""
18
19 DOCS=( ChangeLog )
20
21 src_prepare() {
22         default
23
24         # Remove bundled getopt
25         rm -rv thirdparty || die
26
27         # Workarund automake issues
28         sed 's,\(AM_INIT_AUTOMAKE(\[\),\1subdir-objects ,' -i configure.ac || die
29
30         eautoreconf
31 }
32
33 src_configure() {
34         econf --enable-doc-rebuild
35 }