*/*: Remove sparc-fbsd keywords
[gentoo.git] / app-misc / editor-wrapper / editor-wrapper-4.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 DESCRIPTION="Wrapper scripts that will execute EDITOR or PAGER"
7 HOMEPAGE="https://www.gentoo.org/"
8 SRC_URI=""
9
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
13 IUSE=""
14
15 S="${WORKDIR}"
16
17 src_prepare() {
18         sed -e 's/@VAR@/EDITOR/g' "${FILESDIR}/${P}.sh" >editor || die
19         sed -e 's/@VAR@/PAGER/g'  "${FILESDIR}/${P}.sh" >pager  || die
20         if use prefix ; then
21                 sed -i \
22                         -e "s:#!/bin/sh:#!/usr/bin/env sh:" \
23                         -e "s: /etc/profile: \"${EPREFIX}/etc/profile\":" \
24                         editor pager || die
25         fi
26 }
27
28 src_install() {
29         exeinto /usr/libexec
30         doexe editor pager
31 }