app-misc/datefudge: version bump
[gentoo.git] / app-misc / datefudge / datefudge-1.22.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit multilib toolchain-funcs eutils
6
7 DESCRIPTION="A program (and preload library) to fake system date"
8 HOMEPAGE="https://packages.qa.debian.org/d/datefudge.html"
9 SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
14 IUSE=""
15
16 PATCHES=()
17
18 pkg_setup() {
19         use userland_BSD && PATCHES+=( "${FILESDIR}"/${P}-bsd.patch )
20 }
21
22 src_prepare() {
23         default
24         sed -i \
25                 -e '/dpkg-parsechangelog/d' \
26                 Makefile || die
27         use prefix && sed -i -e '/-o root -g root/d' Makefile
28 }
29
30 src_compile() {
31         emake CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" VERSION="${PV}"
32 }
33
34 src_install() {
35         emake DESTDIR="${ED}" CC="$(tc-getCC)" libdir="/usr/$(get_libdir)" install
36         einstalldocs
37 }