app-misc/color-1.2-r2: amd64 stable
[gentoo.git] / app-misc / color / color-1.2-r1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="3"
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Easily add ANSI colouring to shell scripts"
9 HOMEPAGE="http://www.runslinux.net/?page_id=10"
10 SRC_URI="http://runslinux.net/projects/color/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
15 IUSE=""
16
17 src_prepare() {
18         epatch "${FILESDIR}"/${PV}-ldflags.patch
19         tc-export CC
20 }
21
22 src_install() {
23         dobin color || die "dobin failed"
24         dodoc CHANGELOG README || die
25
26         # symlink for british users.
27         dosym color /usr/bin/colour || die
28 }
29
30 pkg_postinst() {
31         elog "For information on using colour in your shell scripts,"
32         elog "run \`color\` without any arguments."
33         elog
34         elog "To see all the colours available, use this command"
35         elog "  $ color --list"
36         elog
37         elog "More examples are available in ${EPREFIX}/usr/share/doc/${PF}."
38 }