net-analyzer/hydra: Use Github archive for SRC_URI.
[gentoo.git] / app-misc / carbon-c-relay / carbon-c-relay-3.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs user
7
8 DESCRIPTION="Enhanced C version of Carbon relay, aggregator and rewriter"
9 HOMEPAGE="https://github.com/grobian/carbon-c-relay"
10 SRC_URI="https://github.com/grobian/carbon-c-relay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
15 IUSE=""
16
17 RDEPEND=""
18 DEPEND="${RDEPEND}"
19
20 pkg_preinst() {
21         enewgroup carbon
22         enewuser carbon -1 -1 -1 carbon
23 }
24
25 src_configure() {
26         tc-export CC
27 }
28
29 src_install() {
30         newbin relay ${PN}
31         dodoc ChangeLog.md
32         doman ${PN}.1
33
34         newinitd "${FILESDIR}"/${PN}.initd ${PN}
35         newconfd "${FILESDIR}"/${PN}.confd ${PN}
36 }