dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-misc / byobu / byobu-5.129.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit python-single-r1
8
9 DESCRIPTION="A set of profiles for the GNU Screen console window manager (app-misc/screen)"
10 HOMEPAGE="http://byobu.co"
11 SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P/-/_}.orig.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="screen"
17 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
18
19 RDEPEND="${PYTHON_DEPS}
20         $(python_gen_cond_dep '
21                 dev-libs/newt[${PYTHON_MULTI_USEDEP}]
22         ')
23         screen? ( app-misc/screen )
24         !screen? ( app-misc/tmux )"
25
26 src_prepare() {
27         default
28
29         python_fix_shebang .
30
31         # Set default system backend to screen
32         if use screen ; then
33                 sed -i -e 's/#\(BYOBU_BACKEND\).*/\1="screen"/' etc/byobu/backend || die
34         fi
35 }
36
37 src_install() {
38         default
39
40         # Create symlinks for backends
41         dosym ${PN} /usr/bin/${PN}-screen
42         dosym ${PN} /usr/bin/${PN}-tmux
43
44         docompress -x /usr/share/doc/${PN}
45 }