Remove myself from maintainers
[gentoo.git] / app-misc / beep / beep-1.3-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="The advanced PC speaker beeper"
9 HOMEPAGE="http://www.johnath.com/beep"
10 SRC_URI="http://www.johnath.com/beep/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ppc ppc64 sparc x86"
15 IUSE="suid"
16
17 PATCHES=(
18         "${FILESDIR}/${P}-Makefile.patch"
19         "${FILESDIR}/${P}-CVE-2018-0492.patch"
20 )
21
22 pkg_setup() {
23         tc-export CC
24 }
25
26 src_install() {
27         dobin beep
28         if use suid; then
29                 fowners :audio /usr/bin/beep
30                 fperms 4710 /usr/bin/beep
31         else
32                 fperms 0711 /usr/bin/beep
33         fi
34         unpack "./${PN}.1.gz"
35         doman "${PN}.1"
36         einstalldocs
37 }