sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / app-misc / beancounter / beancounter-0.8.10-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit perl-module
7
8 DESCRIPTION="Finance performance calculation engine with full data acquisition, SQL support"
9 HOMEPAGE="http://dirk.eddelbuettel.com/code/beancounter.html"
10 SRC_URI="http://eddelbuettel.com/dirk/code/${PN}/${PN}_${PV}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE="mysql postgres sqlite"
16
17 DEPEND="dev-perl/Date-Manip
18         dev-perl/Statistics-Descriptive
19         dev-perl/Finance-YahooQuote
20         dev-perl/libwww-perl
21         mysql? ( dev-perl/DBD-mysql )
22         sqlite? ( dev-perl/DBD-SQLite )
23         postgres? ( dev-perl/DBD-Pg )"
24
25 RDEPEND="${DEPEND} dev-perl/DBI"
26 mydoc="README example.beancounterrc beancounter_*.txt "
27
28 src_install() {
29         perl-module_src_install
30         # rm unwanted READMEs
31         rm "${D}"usr/share/doc/${PF}/{README.Debian,README.non-gnu} || die
32 }