mail-client/thunderbird: amd64 & x86 stable
[gentoo.git] / app-metrics / process-exporter / process-exporter-0.4.0.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 EGO_PN=github.com/ncabatoff/process-exporter
6
7 inherit golang-build golang-vcs-snapshot systemd
8
9 DESCRIPTION="Process exporter for prometheus"
10 HOMEPAGE="https://github.com/ncabatoff/process-exporter"
11 SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64"
16
17 RESTRICT="strip"
18
19 src_compile() {
20         pushd "src/${EGO_PN}" || die
21         GOPATH="${S}" emake build
22 }
23
24 src_install() {
25         pushd "src/${EGO_PN}" || die
26         dobin ${PN}
27 dodoc *.md
28         insinto /etc/${PN}
29         doins packaging/conf/all.yaml
30         systemd_dounit packaging/${PN}.service
31         newinitd "${FILESDIR}"/${PN}.initd ${PN}
32 }