app-metrics/collectd: add write_stackdriver plugin
[gentoo.git] / app-metrics / openvpn_exporter / openvpn_exporter-0.2.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 EGO_VENDOR=(
7         "github.com/prometheus/client_golang f504d69affe11ec1ccb2e5948127f86878c9fd57"
8         "github.com/beorn7/perks 3a771d992973f24aa725d07868b467d1ddfceafb"
9         "github.com/golang/protobuf e09c5db296004fbe3f74490e84dcd62c3c5ddb1b"
10         "github.com/prometheus/client_model 99fa1f4be8e564e8a6b613da7fa6f46c9edafc6c"
11         "github.com/prometheus/common 38c53a9f4bfcd932d1b00bfc65e256a7fba6b37a"
12         "github.com/matttproud/golang_protobuf_extensions c12348ce28de40eed0136aa2b644d0ee0650e56c"
13         "github.com/prometheus/procfs 780932d4fbbe0e69b84c34c20f5c8d0981e109ea"
14         )
15
16 inherit user golang-build golang-vcs-snapshot
17
18 EGO_PN="github.com/kumina/openvpn_exporter"
19 ARCHIVE_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
20 KEYWORDS="~amd64"
21
22 DESCRIPTION="Prometheus Exporter for OpenVPN"
23 HOMEPAGE="https://github.com/kumina/openvpn_exporter"
24 SRC_URI="${ARCHIVE_URI}
25         ${EGO_VENDOR_URI}"
26 LICENSE="Apache-2.0 BSD MIT"
27 SLOT="0"
28 IUSE=""
29
30 pkg_setup() {
31         enewgroup ${PN}
32         enewuser ${PN} -1 -1 -1 ${PN}
33 }
34
35 rc_compile() {
36         pushd src/${EGO_PN} || die
37         GOPATH="${S}" \
38                 go build -v -o ${PN} || die
39         popd || die
40 }
41
42 src_install() {
43         dobin ${PN}
44         dodoc src/${EGO_PN}/{CHANGELOG,README}.md
45         local dir
46         for dir in /var/{lib,log}/${PN}; do
47                 keepdir "${dir}"
48                 fowners ${PN}:${PN} "${dir}"
49         done
50         newinitd "${FILESDIR}"/${PN}.initd ${PN}
51         newconfd "${FILESDIR}"/${PN}.confd ${PN}
52         insinto /etc/logrotate.d
53         newins "${FILESDIR}/${PN}.logrotated" "${PN}"
54 }