app-metrics/collectd: arm stable wrt bug #704342
[gentoo.git] / app-metrics / nginx-lua-prometheus / nginx-lua-prometheus-0.1_pre20170610.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # This is the upstream tag which corresponds to this release.
7 # It needs to be updated with every bump.
8 TAG="0.1-20170610"
9
10 inherit toolchain-funcs
11
12 DESCRIPTION="Library that exports Nginx metrics to Prometheus"
13 HOMEPAGE="https://github.com/knyar/nginx-lua-prometheus"
14 SRC_URI="https://github.com/knyar/${PN}/archive/${TAG}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0"
18 KEYWORDS="~amd64"
19
20 COMMON_DEPEND=">=dev-lang/lua-5.1:="
21 DEPEND="${COMMON_DEPEND}"
22 RDEPEND="${COMMON_DEPEND}
23         www-servers/nginx[nginx_modules_http_lua]"
24 BDEPEND="${COMMON_DEPEND}
25         virtual/pkgconfig"
26
27         S="${WORKDIR}/${PN}-${TAG}"
28
29 src_install() {
30         insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
31         doins prometheus.lua
32         dodoc *.md
33 }