www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / app-leechcraft / lc-xproxy / lc-xproxy-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit leechcraft
7
8 DESCRIPTION="Provides advanced proxy support features for LeechCraft"
9
10 SLOT="0"
11 KEYWORDS=""
12 IUSE="debug"
13
14 DEPEND="~app-leechcraft/lc-core-${PV}
15         dev-qt/qtnetwork:5
16         dev-qt/qtwidgets:5
17 "
18 RDEPEND="${DEPEND}"
19
20 pkg_postinst() {
21         if ! has_version app-leechcraft/lc-qrosp || ! has_version dev-libs/qrosspython; then
22                 einfo "XProxy supports scriptable host lists to match, for example, against all sites in RosKomNadzor registry."
23                 einfo "Install app-lc/lc-qrosp and dev-libs/qrosspython to support these."
24         fi
25 }