www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / app-leechcraft / lc-vrooby / lc-vrooby-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit leechcraft
7
8 DESCRIPTION="Vrooby, removable device manager for LeechCraft"
9
10 SLOT="0"
11 KEYWORDS=""
12 IUSE="debug"
13
14 DEPEND="~app-leechcraft/lc-core-${PV}
15         dev-qt/qtdbus:5
16         dev-qt/qtdeclarative:5[widgets]
17         dev-qt/qtwidgets:5
18 "
19 RDEPEND="${DEPEND}
20         sys-fs/udisks:2"
21
22 src_configure() {
23         local mycmakeargs=(
24                 -DENABLE_VROOBY_UDISKS=OFF
25                 -DENABLE_VROOBY_UDISKS2=ON
26         )
27         cmake_src_configure
28 }