app-leechcraft/lc-azoth: bump EAPI, add subslot ops
[gentoo.git] / app-leechcraft / lc-secman / lc-secman-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit leechcraft
7
8 DESCRIPTION="Security and personal data manager for LeechCraft"
9
10 SLOT="0"
11 KEYWORDS=""
12 IUSE="debug crypt exposecontents"
13
14 DEPEND="~app-leechcraft/lc-core-${PV}
15         crypt? ( dev-libs/openssl:0 )
16         dev-qt/qtwidgets:5
17 "
18 RDEPEND="${DEPEND}"
19
20 src_configure() {
21         local mycmakeargs=(
22                 -DENABLE_SECMAN_SECURESTORAGE=$(usex crypt)
23                 -DWITH_SECMAN_EXPOSE_CONTENTSDISPLAY=$(usex exposecontents)
24         )
25
26         cmake-utils_src_configure
27 }