app-leechcraft/lc-azoth: bump EAPI, add subslot ops
[gentoo.git] / app-leechcraft / lc-otlozhu / lc-otlozhu-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit leechcraft
7
8 DESCRIPTION="Otlozhu, a GTD-inspired ToDo manager plugin for LeechCraft"
9
10 SLOT="0"
11 KEYWORDS=""
12 IUSE="debug"
13
14 DEPEND="~app-leechcraft/lc-core-${PV}
15         dev-qt/qtnetwork:5
16         dev-qt/qtwidgets:5
17         dev-qt/qtxml:5
18 "
19 RDEPEND="${DEPEND}"
20
21 src_configure() {
22         local mycmakeargs=(
23                 -DENABLE_OTLOZHU_SYNC=OFF
24         )
25
26         cmake-utils_src_configure
27 }