app-leechcraft: use Qt5, modernize the eclass and ebuilds
[gentoo.git] / app-leechcraft / lc-lhtr / lc-lhtr-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 inherit leechcraft
8
9 DESCRIPTION="LeechCraft HTML Text editoR component"
10
11 SLOT="0"
12 KEYWORDS=""
13 IUSE="debug"
14
15 DEPEND="~app-leechcraft/lc-core-${PV}
16         app-text/tidy-html5
17         dev-qt/qtnetwork:5
18         dev-qt/qtwidgets:5
19         dev-qt/qtwebkit:5
20 "
21 RDEPEND="${DEPEND}"