app-leechcraft/lc-kbswitch: use pkg_postinst suggestion instead of RDEPEND
[gentoo.git] / app-leechcraft / lc-kbswitch / lc-kbswitch-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils leechcraft
7
8 DESCRIPTION="Provides plugin- or tab-grained keyboard layout control"
9
10 SLOT="0"
11 KEYWORDS=""
12 IUSE="debug"
13
14 DEPEND="~app-leechcraft/lc-core-${PV}
15         dev-qt/qtnetwork:5
16         dev-qt/qtwidgets:5
17         dev-qt/qtx11extras:5
18         dev-qt/qtdeclarative:5[widgets]
19 "
20 RDEPEND="${DEPEND}
21         x11-apps/setxkbmap
22         "
23
24 pkg_postinst() {
25         elog "Consider installing the following for additional features:"
26         optfeature "display layout indicator in LeechCraft tray" virtual/leechcraft-quark-sideprovider
27 }