app-leechcraft/lc-kbswitch: bump to EAPI=7
[gentoo.git] / app-leechcraft / lc-kbswitch / lc-kbswitch-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit eutils leechcraft
7
8 DESCRIPTION="Provides plugin- or tab-grained keyboard layout control"
9
10 SLOT="0"
11 KEYWORDS=""
12 IUSE="debug"
13
14 DEPEND="~app-leechcraft/lc-core-${PV}
15         dev-qt/qtdeclarative:5[widgets]
16         dev-qt/qtwidgets:5
17         dev-qt/qtx11extras:5
18 "
19 RDEPEND="${DEPEND}
20         x11-apps/setxkbmap
21 "
22
23 pkg_postinst() {
24         elog "Consider installing the following for additional features:"
25         optfeature "display layout indicator in LeechCraft tray" virtual/leechcraft-quark-sideprovider
26 }