dev-libs/libuv: ppc64 stable (bug 607222).
[gentoo.git] / app-leechcraft / lc-blasq / lc-blasq-0.6.60.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit leechcraft
8
9 DESCRIPTION="Cloud image storage services client (like Flickr or Picasa)"
10
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE="debug +deathnote +rappor +spegnersi +vangog"
14
15 DEPEND="~app-leechcraft/lc-core-${PV}
16                 deathnote? ( dev-qt/qtxmlpatterns:4 )
17                 spegnersi? ( dev-libs/kqoauth )
18                 vangog? ( dev-libs/qjson )
19                 "
20 RDEPEND="${DEPEND}"
21
22 src_configure(){
23         local mycmakeargs=(
24                 $(cmake-utils_use_enable deathnote BLASQ_DEATHNOTE)
25                 $(cmake-utils_use_enable rappor BLASQ_RAPPOR)
26                 $(cmake-utils_use_enable spegnersi BLASQ_SPEGNERSI)
27                 $(cmake-utils_use_enable vangog BLASQ_VANGOG)
28         )
29
30         cmake-utils_src_configure
31 }