dev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946
[gentoo.git] / app-laptop / tpb / tpb-0.6.4-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit linux-info eutils
6
7 DESCRIPTION="IBM ThinkPad buttons utility"
8 HOMEPAGE="https://savannah.nongnu.org/projects/tpb/"
9 SRC_URI="https://savannah.nongnu.org/download/tpb/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 -ppc x86"
14 IUSE="nls xosd"
15
16 RDEPEND="x11-libs/libXt
17         x11-libs/libXext
18         xosd? ( >=x11-libs/xosd-2.2.0 )"
19 DEPEND="${RDEPEND}"
20
21 CONFIG_CHECK="~NVRAM"
22 ERROR_NVRAM="${P} requires /dev/nvram support (CONFIG_NVRAM)"
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${PN}-configure-fix.diff
26         epatch "${FILESDIR}"/${P}-nvram.patch
27 }
28
29 src_configure() {
30         econf \
31                 $(use_enable nls) \
32                 $(use_enable xosd)
33 }
34
35 src_install() {
36         default
37         dodoc doc/{callback_example.sh,nvram.txt,tpbrc}
38 }