app-laptop/tpacpi-bat: use #!/sbin/openrc-run instead of #!/sbin/runscript
[gentoo.git] / app-laptop / tpacpi-bat / tpacpi-bat-1.1-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils systemd
8
9 if [ "${PV}" = "9999" ]; then
10         inherit git-2
11         EGIT_REPO_URI="git://github.com/teleshoes/tpacpi-bat.git https://github.com/teleshoes/tpacpi-bat.git"
12         KEYWORDS=""
13 else
14         SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64"
16 fi
17 DESCRIPTION="Control battery thresholds of recent ThinkPads, which are not supported by tp_smapi"
18 HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
19
20 LICENSE="GPL-3"
21 SLOT="0"
22 IUSE=""
23
24 DEPEND=""
25 RDEPEND="sys-power/acpi_call
26         dev-lang/perl"
27
28 src_install() {
29         dodoc README battery_asl
30         dobin tpacpi-bat
31         newinitd "${FILESDIR}"/${PN}.initd.1 ${PN}
32         newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}
33         systemd_newunit tpacpi.service ${PN}.service
34 }