app-laptop/batti: Drop old
[gentoo.git] / app-laptop / nvidiabl / nvidiabl-0.83.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit linux-mod
6
7 DESCRIPTION="Linux driver for setting the backlight brightness on laptops using
8 NVIDIA GPU"
9 HOMEPAGE="https://github.com/guillaumezin/nvidiabl"
10 SRC_URI="https://github.com/guillaumezin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND=""
19
20 RESTRICT="test"
21
22 BUILD_TARGETS="modules"
23 MODULE_NAMES="nvidiabl()"
24
25 pkg_pretend() {
26         CONFIG_CHECK="FB_BACKLIGHT"
27         ERROR_FB_BACKLIGHT="Your kernel does not support FB_BACKLIGHT. To enable you
28 it you can enable any frame buffer with backlight control or nouveau.
29 Note that you cannot use FB_NVIDIA with nvidia's proprietary driver"
30         linux-mod_pkg_setup
31 }
32
33 src_compile() {
34         BUILD_PARAMS="KVER=${KV_FULL}"
35         MAKEOPTS+=" V=1"
36         linux-mod_src_compile
37 }